Sales: 833-641-1814 - Service: 585-582-1600

A high severity vulnerability is actively being exploited by attackers to target Chrome users. This affects web browsing software for all major operating systems including Windows, macOS, and Linux. If you open or are redirected to a specifically-crafted webpage without further interaction, you will be affected. In order to deter this exploitation, you need to make sure that Google Chrome has been updated.

Click for more information about Google Chrome’s ongoing issue.

Comment